Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 26, 2026 - 17:00 EST
Scheduled
Release a new version of the Account that fixed the double Authorization header issue with minimum impact to end-users. The change will be released to CloudApps in a rolling fashion, one node at a time, so the impact to users should be minimal, if any.
Posted Feb 23, 2026 - 13:06 EST
This scheduled maintenance affected: Identity Access Management (Duo Two-Step Verification) and Office 365 (Multi-Factor Authentication (MFA)).