tarheels.live outage
Incident Report for UNC Chapel Hill - ITS
Resolved
This incident has been resolved.
Posted Sep 24, 2021 - 11:56 EDT
Identified
Websites hosted on tarheels.live are currently experiencing problems. ITS staff are working to resolve the issue.
Posted Sep 24, 2021 - 11:44 EDT
This incident affected: Other Services.