DNS Issues Affecting Multiple Services

Incident Report for UNC Chapel Hill - ITS

Resolved

This inicdent has been resolved.

This issue has been resolved. The root cause was an issue within the virtualization platform.

Posted Apr 27, 2026 - 16:40 EDT

Update

ITS has seen the situation was transient, and is currently investigating the root cause, which may be external to DNS.
Posted Apr 27, 2026 - 15:02 EDT

Update

Issues with DNS may cause issues across various services. Engineers are working currently to investigate
Posted Apr 27, 2026 - 14:53 EDT

Investigating

ITS has detected issues with Infoblox affecting DNS infrastructure around 2:30PM. Engineers are currently investigating and updates will be provided as available.
Posted Apr 27, 2026 - 14:51 EDT
This incident affected: Network (Campus DNS).