TEACCH Asheville Technology Drive Network Problem Detected

Incident Report for UNC Chapel Hill - ITS

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 01:39 EDT

Investigating

Our monitoring tools have indicated a possible network issue at TEACCH Asheville Technology Drive. Engineers are investigating and will post updates as they become available. If you have any questions contact 962-HELP.
Posted Mar 21, 2025 - 01:20 EDT
This incident affected: Network (Campus Building Networks).